PAT甲级 1035.Password (20 分)

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1(one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:

1
2
3
4
3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

1
2
3
2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
2
1
team110 abcdefg332

Sample Output 2:

1
There is 1 account and no account is modified

Sample Input 3:

1
2
3
2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

1
There are 2 accounts and no account is modified

分析:

题目要求:给定N个用户账号(包含用户名和密码),将密码中的1(数字一)替换为@0(数字零)替换为%l(小写字母)替换为LO(大写字母)替换为o

输出被更改的账号个数M,以及被更改账号的用户名和更改后的密码。

若没有账户需要更改,输出There are N accounts and no account is modified,其中N为账号个数。特别地,当N为1时,输出There is 1 account and no account is modified

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
#include <cstdio>
#include <cstring>

struct Account {
char username[11];
char password[11];
};

int main() {
int n;
scanf("%d", &n);
struct Account accounts[n];
int len = 0;
for (int i = 0; i < n; i++) {
struct Account a;
getchar();
scanf("%s %s", a.username, a.password);
bool isModified = false;
for (int j = 0; j < strlen(a.password); j++) {
switch(a.password[j]) {
case 'l':
a.password[j] = 'L';
isModified = true;
break;
case '1':
a.password[j] = '@';
isModified = true;
break;
case '0':
a.password[j] = '%';
isModified = true;
break;
case 'O':
a.password[j] = 'o';
isModified = true;
break;
}
}
if (isModified) {
accounts[len++] = a;
}
}
if (len == 0) {
if (n == 1) {
printf("There is 1 account and no account is modified\n");
} else {
printf("There are %d accounts and no account is modified\n", n);
}
} else {
printf("%d\n", len);
for (int i = 0; i < len; i++) {
struct Account a = accounts[i];
printf("%s %s\n", a.username, a.password);
}
}
return 0;
}

----------本文结束感谢您的阅读----------
坚持原创技术分享,您的支持将鼓励我继续创作!